Wi-CAT LLC

Wireless Comprehensive Advanced Technology. Build your network now.

Wi-CAT LLC
Навигация Форума
Вы должны войти, чтобы создавать сообщения и темы.

(решено) После загрузки устройства требуется переподключать провод в wan

Здравствуйте, в продолжение этой темы https://wi-cat.ru/forums/topic/sypet-i-ikaet-iptv-na-provajdere-onlajm/

Выявил закономерность что при поднятии линка нужно вытащить провод из wan и вставить обратно и после этого перестает подсыпать ТВ.
Причем вынимать провод нужно однажды после перезагрузки либо обновлении прошивки либо изменении настроек порта либо изменении настроек вайфая, нужно однократно вытащить и вставить провод, и это работает  до следующей перезагрузки.
На SNR CPE ME1 этого не требуется, похоже сам переподнимается порт, хотя Вам виднее что происходит там и что у вас. Возможно что-то придумать чтобы не приходилось провод дергать каждый раз.

П.С. После передергивания порта, что-бы не сыпало под нагрузкой всеравно необходимо выставить HW_NAT binding threshold в 0 либо выделить TV port, но это не как не сказывается на работе.

Ещё раз повторюсь, что логика в ME1 и DUO-G на тему коммутатора в нашем ПО абсолютно идентична. И свитч аппаратно один и тот же. По сути вся разница лан сегмента ME1 и DUO-G в трансформаторах и разъёмах.

В пределах параметров заложенных в стандарт гигабит эзернет они работают абсолютно идентично.

А что бы что-то сделать, нужно понимать что происходит с обратной стороны.

При перетыкании порта вообще никакая логика по сути не шевелиться в PurePPPOE. Я не знаю как это диагностировать не видя данных по коммутатору куда включен WAN. И что он говорит по параметрам линка при проблемах и без.

Со стороны DUO-G нужно убедиться что автосогласование отработало корректно заглянув в статистику портов.

Если линия фиговая, то как уже не раз говорил, нужно чинить линию или на худой конец на вводе в квартиру поставить дешовый коммутатор и забыть. Что ещё и при длине линии сверх стандарта позволит избавиться от подземных стуков.

Можно играться с параметрами, городить костыли в виде каких-нить реинитов коммутатора дополнительных или ещё чего, но пока есть проблема с линией подземные стуки будут возникать регулярно.

Если проблема лезет и через промежуточный коммутатор, то это скорее всего брак. Точнее скажет только диагностика в СЦ.

Я насколько вижу с промежуточным коммутатором проблем нет? Ну вот и чего мучать зверушку тады? Ну выдумаю я щас возможно какой-нить адовый костыль, ну просядут ещё параметры линии чрез неделю-две-месяц и опять начнётся. Только уже везде и с отвалами.

 

Вам виднее что происходит там и что у вас.

Мне не ведомо что происходит ТАМ =) Если залита наша Wive-NG-MT то происходит ровно тоже самое что и в HQ. ;)

Цитата: sfstudio от 03/09/2020, 16:46

Я насколько вижу с промежуточным коммутатором проблем нет? Ну вот и чего мучать зверушку тады? Ну выдумаю я щас возможно какой-нить адовый костыль, ну просядут ещё параметры линии чрез неделю-две-месяц и опять начнётся. Только уже везде и с отвалами.

 

Так есть проблемма с промежуточным тоже, а вот если порт в 100 мбит переключить то нормализируется. Когда были доступны прошивки я о данной особенности с перетыканием не знал =) Все чего-то перекрылись=) Помнится на SNR тоже подсыпания были на Wive-NG-MT, теперь фиг проверишь. Просто подумал что эти их правки как-то повлияли

init.d: Disable reinit ethernet switch

init.d: Rework reinit ethernet switch

Либо вы какие-то костыли убрали.

Сдавать в сервис вообще не вариант, 45 дней без интернета, сейчас DUO-G в режиме моста работает =)

Дык я не понял аплинк соточный или гигабитный? В чём проблема переключить в сотку (если соточный) и жить спокойно дальше?

Правки там по свитчу чисто в оптимизации реконфигура и выкидывания костылей. Дампы регистров до и после правок совпадают полностью.

Если бы дело было бы в ПО, и реально были бы подсыпания на нормальной линии, то ни один тест ни у одного провайдера входной оборудование бы не прошло. Вот вообще. Работа IPTV это второй по важности кейз тестируемый операторами.

Да и в т.ч. я лично использую iptv от провайдера. И линия у меня с превышением длины, и воткнута напрямую.

Что за свитч-то? Мож найду в радиусе доступа попробую эмулировать раз через него повторяется.

Может тупо контакты уже окислились в коннекторе и на DUO-G контакт так себе получается. Конструкция портов на DUO-G несколько иная. Может в вашем случае контакт хуже в итоге. Хотя у меня вон на сетевых хвостах долго девайс висел ибо шурупчик вкрутить было некогда. =)

Ради интереса можно проверить сказав по ssh service network restart и дождаться реконфигура сети помогает или нет. Это застваит железку переконфигурить сеть и ещё раз моргнуть свитчём.

В логах что-то есть? И т.д. и т.п.

Мало данных, не знаю чем помочь при таких вводных.

Я могу подключить DUO-G обратно для проверки, будут ли подсыпания если запустить без провода и подключить его после загрузки. Это как-то сможет помочь? Если подсыпаний не будет это тоже брак?

Цитата: sfstudio от 03/09/2020, 17:18

Дык я не понял аплинк соточный или гигабитный? В чём проблема переключить в сотку (если соточный) и жить спокойно дальше?

Правки там по свитчу чисто в оптимизации реконфигура и выкидывания костылей. Дампы регистров до и после правок совпадают полностью.

Если бы дело было бы в ПО, и реально были бы подсыпания на нормальной линии, то ни один тест ни у одного провайдера входной оборудование бы не прошло. Вот вообще. Работа IPTV это второй по важности кейз тестируемый операторами.

Да и в т.ч. я лично использую iptv от провайдера. И линия у меня с превышением длины, и воткнута напрямую.

Что за свитч-то? Мож найду в радиусе доступа попробую эмулировать раз через него повторяется.

Может тупо разъемы уже окислились в коннекторе и на DUO-G контакт так себе получается. Конструкция портов на DUO-G несколько иная. Может в вашем случае контакт хуже в итоге. Хотя у меня вон на сетевых хвостах долго девайс висел ибо шурупчик вкрутить было некогда. =)

Тариф 500 мбит линк 1гб, но если переключить на сотку то тоже работает, есть плойка 4 в нем ssd на 256 гб, часто игры перекачиваю и на 100 мбитах при весе современных игр совсем грустно. Свич tl-sg1005d v5

Да вот не знаю чем это может помочь.  Коммутатор там аппаратный полностью. Т.е. по перетыканию провода ничего не дёргается в нём из софта. EEE вырубается драйвером, но это логике уже лет 5ть.

В общем идеальный вариант это повторить у меня. Второй вариант - воткнуть напрямую и смотреть на обратной стороне что происходит начиная от параметров на которых согласовался линк до счётчиков ошибок общих и по мультикасту в отдельности.

И т.д. и т.п.

Я ж тоже сам это оборудование использую на постоянку. Как у себя так у родителей, друзей и т.д. И ещё в первый раз специально у всех спросил никто не замечал ли чего подобного.

Кстати. Для проверки, запитайте DUO-G питальником от ME1 они по параметрам подходящие. Может таки с БП чего лезет и свитч в 7621 от этого подколбашивает временами.

 

по ssh service network restart попробую завтра послезавтра

Цитата: sfstudio от 03/09/2020, 17:26

Да вот не знаю чем это может помочь.  Коммутатор там аппаратный полностью. Т.е. по перетыканию провода ничего не дёргается в нём из софта. EEE вырубается драйвером, но это логике уже лет 5ть.

В общем идеальный вариант это повторить у меня. Второй вариант - воткнуть напрямую и смотреть на обратной стороне что происходит начиная от параметров на которых согласовался линк до счётчиков ошибок общих и по мультикасту в отдельности.

И т.д. и т.п.

Я ж тоже сам это оборудование использую на постоянку. Как у себя так у родителей, друзей и т.д. И ещё в первый раз специально у всех спросил никто не замечал ли чего подобного.

Кстати. Для проверки, запитайте DUO-G питальником от ME1 они по параметрам подходящие. Может таки с БП чего лезет и свитч в 7621 от этого подколбашивает временами.

 

БП ставил, даже помощьнее подключал на 3a непомогает.

Монтажников тоже вызывал, но толку от них, ошибок на порте нет на прямую приставка не сыпет (и не колышет их что порт у приставки 100мбит) и линк короткий я на верхнем этаже а свитч на чердаке в соседнем подьезде. Перезалили настройки на порте свича перезапустили и развели руки =) Скрутки есть но при такой длине линка типо влиять не может.

Вопрос не в мощности на самом деле.

Ладно. Есть у меня свитч на том же чипе что и tl-sg1005d v5, попробую поставить его на ввод у себя.

Кстати зажать в 1Гбит + вырубить контроль потока не решает траблы? Ну т.е. линк таки фиксировать в гигабите и поиграться с контролем потока.

Цитата: kip от 03/09/2020, 17:31

Монтажников тоже вызывал, но толку от них, ошибок на порте нет на прямую приставка не сыпет (и не колышет их что порт у приставки 100мбит) и линк короткий я на верхнем этаже а свитч на чердаке в соседнем подьезде. Перезалили настройки на порте свича перезапустили и развели руки =)

Чудеса... Ну бум посмотреть. Воткну свитч у себя на вводе промежуточный и понаблюдаю для 2-3.

Сеть у меня гигабитная внутри вся. ТВ ни на одном порту не сыпет. Попробую эмулировать вашу ситуацию хоть таким методом.

Цитата: sfstudio от 03/09/2020, 17:32

Вопрос не в мощности на самом деле.

Ладно. Есть у меня свитч на том же чипе что и tl-sg1005d v5, попробую поставить его на ввод у себя.

Кстати зажать в 1Гбит + вырубить контроль потока не решает траблы? Ну т.е. линк таки фиксировать в гигабите и поиграться с контролем потока.

Пробовал не помогло. Вынимаешь вставляешь провод и все отлично до следующей перезагрузки как описывал выше.

Чудеса одно слово... Пока у меня идеи кончились.

Причем если брак то очень странный, проявляется только при перезагрузках либо включении и изменении настроек wifi возможно еще где-то где дергается встроеный свич, и достаточно однократного передергивания провода в wan, даже если несколько раз вынуть вставить провод в wan то проблема не появляется.

Процедуры что просто при загрузке что при применении настроек что при софт ребуте со свитчём одни и те же выполняются. Вот вообще.

Я сравню на днях на всякий случай дампы регистров свитча что бы убедиться что без изменении настроек в регистрах до и после "передёргивания" ничего не меняется. Мож чего выясниться.

Но там только костыль для отключения EEE работает в момент передёргивания и ему уже лет дофига.

В общем подозрительные чудеса, учитывая что я пока у себя не вижу проявлений (воткнул свичт в разрыв для эмуляции).

Пробуйте 2.8.6, кажется поймал в паре с коммутатором на гигабитном риалтэке буквально чудо. Пришлось ввернуть один старый костылик в ините и немного расширить другой в дровине.

Правда к рассыпаниям никаким в моём случае это не приводило, что логично, ибо LPI режим эт вполне штатная штука для современных свитчей и если обе стороны умеют и уровней с запасом то почему бы и нет.

Ну и остаётся вопрос повторяемости у вас. У меня это происходило 1 раз из 100 реконфигуров свитча. Т.е. если поможет остаётся вопрос почему в вашем случае повторяемость столь высока.

Если нет, ну значит не оно и идеи снова иссякли.

Помогло!!! Больше дергать провод ненадо, более того, никаких иканий и зелени на тв, даже намека нет, даже по нагрузкой, сейчас со значеним HW_NAT binding threshold = 5 (значение по умолчани сейчас (после сброса), ранее ставил это значение (5) вручную не помогало, сыпало под нагрузкой всё что отлично от 0) сейчас работает ИДЕАЛЬНО.
Огромное спасибо, просто ОГРОМНЕЙШЕЕЕ СПАСИБО. УраЙ!! Вы просто кудесник!!!

Менял настройки wifi дважды, ничего не отключая (второй раз забыл название сети поменять), бага НЕ вернулась, всё идеально, (запустил ~50 мегабайт торрента), всё идеально, даже намека на зелень икания либо тормоза нет.

Еще раз СПАСИБО!

Попробовал поставить HW_NAT binding threshold = 50, ничего не сыпет. Начинает подсыпать под нагрузкой (торрент ~50 мегабайт)  если NAT offload mode перевести в Disable или Software.

Ну и хорошо... Честно не улавливаю связи между LPI и PPE и т.д. Причём что повторения у меня как не было так и нет. Ну ок. Знач пометим, что эти воркэраунды должны оставаться дабы при очередном рефакторинге не вынести.

 

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: