Wi-CAT LLC

Wireless Comprehensive Advanced Technology. Build your network now.

Wi-CAT LLC
Навигация Форума
Вы должны войти, чтобы создавать сообщения и темы.

Не цепляются клиенты в режиме Точки доступа.

Квартира. Есть FT-AIR-DUO-G, на днях взял второй такой-же, заменив им коммутатор в дальней комнате. Т.е. один FT-AIR-DUO-G работает как шлюз+AP, второй подключен к нему по проводу и работает в режиме AP. На обоих созданы беспроводные сети с одинаковыми ssid и паролями. На обоих включен 802.11 k/r/v. Так вот к второму, который только AP не подключаются клиенты по WiFi. Подключаю телефон к сети 5GHz, он проходит авторизацию, надпись "получение ip адреса" и отвал через 30 секунд. Потом он сразу пытается подключиться к сети 2.4GHz, проходит авторизацию, 30 секунд горит надпись "получение ip адреса" и отвал. И так много раз. Причем изредка бывает, что телефон подключается сразу, но если переключить руками на другую сеть, то опять не может подключиться. Клиенты разные, два телефона и планшет, всё на андроид. Чтоб подключится нужно уйти в зону, где лучше сигнал у того роутера, который шлюз+AP, с ним проблем нет. К роутеру, который только AP подключено несколько клиентов по проводу, с ними всё ок. Не могу понять, может сам что не так сделал... Прошивка 2.7.10. На 2.7.8 было тоже самое. Как мне показалось, на 2.7.9 дело обстояло гораздо лучше, клиенты цеплялись мгновенно, но она была всего день, потом обновил на 2.7.10.

Линк-то есть вообще между железками?

Отличия 2.7.8-10 только в правках в морде (webui). Видимо с кабелем который соединяет AP не так. Проверьте в статусе портов что с линком и физически обжато верно ли по цветам. Т.е. A-A или B-B и все пары.

 

Если с линком всё ОК то конфиги и с AP и с роутера мне на sfstudio[at]wi-cat.ru посмотрю что не так.

P.S. Что ж блин за закон подлости вечный. Как уедешь так начинается =) Давайте проверяйте. Скорее всего с линком что-то не так. Мож недожат коннектор или ещё что. Раз не может получить адрес, то значит связи нет между АП и роутером, т.к. DHCP в такой схеме живёт только на роутере.

Цитата: sfstudio от 17/07/2020, 22:57

Линк-то есть вообще между железками?

Отличия 2.7.8-10 только в правках в морде (webui). Видимо с кабелем который соединяет AP не так. Проверьте в статусе портов что с линком и физически обжато верно ли по цветам. Т.е. A-A или B-B и все пары.

 

По LAN всё ок. Линк точно есть, к AP по кабелю подключена спутниковая приставка, для которой пропадание интернета на 10 секунд приводила бы к отвалу ТВ, но этого не происходит. Так-же от AP по кабелю подключен коммутатор в комнате ребенка, а там (тоже по кабелю) его комп, принтер и андроид приставка, он играет в GTA онлайн и жаловаться не приходил. Хотя когда обновляю прошивку и интернет пропадает на пару минут сын быстро появляется рядом =) Сейчас со своего компьютера (он подключен кабелем к шлюзу) попинговал AP 10000 пакетами. Потерянных пакетов нет, 99% задержек это 1-2 мс. Когда пинговал пробовал цепляться с телефона - то-же самое. Конфиги отправил Вам на почту. Надеюсь не наделал глупых ошибок )

Очень как-то это всё странно. Там накосячить не где. Конфиги увы смогу глянуть только наверное послезавтра. Как грил уже в командировке и с самого утра в дорогу опять ;(

Давайте вот ради интереса сделаем так. На АП сброс резетом и настройка минимальная, переключение в режим AP-Bridge смена логина и пароля + SSID включение k/r/v и всё. Можно даже V на время проверки не включать.

И вот конфиг в этом виде мне.

У меня дома схема 2 AP + роутер. Т.е. именно та же самая что у вас, т.к. это типовая нынче конфигурация. Проблем не замечено.

P.S. Глупые ошибки это фигня. Один раз разобраться и понять и всё. Не ошибается тот кто ничего не делает.

Цитата: sfstudio от 18/07/2020, 00:04

И вот конфиг в этом виде мне.

Сделал, как Вы сказали. Сбросил кнопкой, установил пароль на подключение к устройству, перевел в режим АР, задал SSID и пароль, включил k/r. Пробую подсоединиться - первое подключение мгновенное, казалось, что всё заработало. Потом руками переключаюсь между 2.4GHz и 5GHz и всё стало, как писал раньше - долгое получение ip адреса и отвал. На телефоне жены выглядит чуть иначе. Попытка подключение к 5GHz, мгновенно отвал, подключение к 2.4GHz, тоже сразу отвал. После телефон видит обе сети но не пытается к ним подключаться. Подключаюсь руками, первая сеть - сразу отвал, вторая сеть - сразу отвал. Отправил конфиг Вам на почту. В принципе проблема совершенно не срочная, один роутер покрывает всю квартиру, второй я купил так... чтоб красиво было.

Перечитал своё предыдущее сообщение. Его можно было не правильно понять (особенно про ТВ), отредактировал, сейчас ок.

Ок. Как только будет минутка гляну конфиги. Ибо сиё есть прям чудеса чудесные. Не откуда в такой схеме взяться проблемам даже потенциально в лоб.

А что за телефоны-то такие ? Лог с роутера и AP в момент проблем с подключением тоже бы надо туда же на мыло сразу.

Если 802.11R отрубить на обоих девайсах ситуация не нормализуется? Встречал поведение подобное на Samsung J100 помойму. Там увы беда, они не умеют R да ещё и начинают глючить при его наличии на AP.

В конфигах в лоб криминала не вижу. Т.е. если физика исправна то всё должно быть ОК.

Набор протоколов на АП и роутере должен быть одинаковый включен. У вас сейчас V включено на роутере и вырублено на АП. Тоже может приводить к глюкам клиента.

Попробуйте сначала отрубить все роуминговые расширения, затем воткнуть только RRM ну и т.д. опция за опцией на АП и роутере, методом исключения выяснить на что ваши клиенты так реагируют.

Возможно я даже такие устройства где-то найду для повторения у себя.

Цитата: sfstudio от 18/07/2020, 09:46

Если 802.11R отрубить на обоих девайсах ситуация не нормализуется? Встречал поведение подобное на Samsung J100 помойму. Там увы беда, они не умеют R да ещё и начинают глючить при его наличии на AP.

В конфигах в лоб криминала не вижу. Т.е. если физика исправна то всё должно быть ОК.

Набор протоколов на АП и роутере должен быть одинаковый включен. У вас сейчас V включено на роутере и вырублено на АП. Тоже может приводить к глюкам клиента.

Попробуйте сначала отрубить все роуминговые расширения, затем воткнуть только RRM ну и т.д. опция за опцией на АП и роутере, методом исключения выяснить на что ваши клиенты так реагируют.

Возможно я даже такие устройства где-то найду для повторения у себя.

У меня на роутере и на AP было включено V в первом письме, когда Вы ещё не сказали его отключать. А во втором письме, где конфиг только AP выключено V, в этот момент у меня и на роутере было выключено V, как Вы и сказали сделать. Телефоны - у меня Xiaomi Mi 9SE, прошивка глобальная стабильная 11.0.6.0 QFBEUXM  на 10 андроиде. У супруги Xiaomi Redmi Note 4, прошивка тоже глобал стэйбел NCFMIXM на 7 андроиде. Загрузчики везде заблокированы, ни каких модификаций. Попробую поотключать расширения для миграции, но это наверное вечером или завтра, сейчас уехал за город )

Цитата: sfstudio от 18/07/2020, 09:46

Попробуйте сначала отрубить все роуминговые расширения, затем воткнуть только RRM ну и т.д. опция за опцией на АП и роутере, методом исключения выяснить на что ваши клиенты так реагируют.

Хотел сегодня поэкспериментировать. Пришел в зону, где у АР более сильный сигнал, подключал и отключал телефон. Всё происходит мгновенно. Между сетями 2.4 и 5 на АР переключает мгновенно. Взял телефон жены, тоже мгновенно подключается. Не знаю, как это объяснить... При этом k/r включены и на роутере и на АР. Включил ещё V на обоих устройствах. Проблемы нет. Жена говорит, что утром она пробовала подключаться и уже утром всё было нормально. Буду каждый день теперь "мониторить". Если поймаю проблему (возможно она вернется) попробую скопировать записи из лога роутера и АР. Их смотреть в Администрирование-системный журнал? Почему-то на АР у меня там пусто. Вообще нет записей.

Видимо что-то на телефонах обновилось в тихушку... Других объяснений нет.

Кстати при включенном RRM АП затрачивает при загрузке около минуты на скан и сбор данных дополнительно. Т.е. если включен RRM стоит подождать некоторое время после загрузки прежде чем пытатьс подключаться, ибо не пустит.

P.S. Сяоми не умеют K/R. Увы.

Несколько дней всё работало отлично, сегодня проблема вернулась. И у меня и у супруги одновременно. Не цепляются клиенты к АР. Логи с роутера и АР выслал Вам на почту. k/v/r при этом включены. Выключил k/v/r - вроде всё стало хорошо.

Осталось выяснить с чем из k/r/v (методом отклюения по очереди) у Xiaomi проблемы и репортить им что бы правили.

Не выяснили от чего именно у ваших клиентов голова отваливается? На правах гадалки от R или V. Не плохо бы выяснить. Другим будет полезно.

Цитата: sfstudio от 07/08/2020, 11:58

Не выяснили от чего именно у ваших клиентов голова отваливается? На правах гадалки от R или V.

Сперва на несколько дней отключил k/r/v - проблем не было. Потом включил только К, проблема появилась на следующий день. Потом включил только R, проблема тоже появилась. Включать только V не пробовал, т.к. понадобился роутер в другом месте, а дома эта AP была не обязательна. Там и основной роутер не плохо покрывал. Опять поставил на место АР обычный проводной коммутатор.

Очень интересно ;) Попадутся эти товарищи китайцы в руки - обязательно попробую повторить... Не зря я как ушёл к самсунгам так и не собираюсь ни куда. =))) Хотя они тоже "хитрят" на младших моделях.

Т.е. поддерживают то они всё, но по факту процедура handover (например в SGS A30S) сломана. И вместо прозрачной миграции получается отключение и реконнеrт полный. Т.е. похоже сломано спецом ибо типа младшие модели и K/R/V они в них не заявляли. ;)

А вот тот же SGS A5 2017 работает как из пушки в тех же условиях. Но там и заявлено было. ;)

Т.е. чисто софтово откручивают голову роумингу у части моделей.

 

Цитата: sfstudio от 07/08/2020, 12:37

Очень интересно ;) Попадутся эти товарищи китайцы в руки - обязательно попробую повторить... Не зря я как ушёл к самсунгам так и не собираюсь ни куда. =))) Хотя они тоже "хитрят" на младших моделях.

Т.е. поддерживают то они всё, но по факту процедура hanover (например в SGS A30S) сломана. И вместо прозрачной миграции получается отключение и реконнет полный. Т.е. похоже сломано спецом ибо типа младшие модели и K/R/V они в них не заявляли. ;)

 

Если получится найти такие аппараты, то было бы интересно узнать результаты. Но признаться я уже успел подостыть к бесшовной миграции )

Ну вот увы да, бардак. Благо хоть что-то года назад у альянса сдвинулось, может ещё через пару лет и клиенты подтянутся и наконец начнут соответвовать тому что в 802.11 описано на эту тему. Сейчас кто в лес, кто по дрова.

Даже рукусы вынуждены советовать отрубать роуминг если наблюдаются проблемы на клиентах.

Лучший роуминг это его отсутсвие (ну когда клиенты разношёрствные или от дядюшки ляо). Т.е. когда всё покрывается одним устройством. Увы не всегда это реально.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: