Wi-CAT LLC

Wireless Comprehensive Advanced Technology. Build your network now.

Wi-CAT LLC
Навигация Форума
Вы должны войти, чтобы создавать сообщения и темы.

(решено, проблема с физикой) Сыпет и икает IPTV на провайдере Онлайм

Провайдер Онлайм подключен гигабитным кабелем к FT-AIR-DUO-G, смотрю IPTV через приставку DuneHD 101 и приложение домашнее тв.
Прошивка 2.7.6 сбросил настройки, изменение от умолчания лишь в установке пароля на вайфай.
Три клиента по проводу из которых две приставки DuneHD 101 и ПК. ПК подключен гигабитом к маршрутизатору и дюны соткой.
Еще какие нибудь настройки нужны?
Через веб tcpdump сделал Interface any Packets to Capture 5000 пакетов в момент просмотра тв, перещелкивая каналы.

Putty и WinSCP есть, если нужно что-нибудь запустить на маршрутизаторе для диагностики.

Еще на вкладке Network Diagnostics одолело сообщение

"Error evaluating /adm/net-overview-update.js: SyntaxError: missing } after property list"

Установка форсирование igmp v2 не помогла.

Я описывал в теме на хоботе что нужно сделать и какие минимально данные предоставить. Вот с этого и начнём. Никакие tcpdump`ы тут не помогут.

  1. проверка и повторение на ПК рассыпаний тех самых, дюны и т.д. это не провайдерские STB, мультикаст там вообще через одно место прикручен. Почти уверен на ПК проблема не повториться.
  2. fastleave выключен?
  3. настройкий файл на контроль на всякий, а то иногда из-за подглючивающего браузера бывает такое в конфигах
  4. Так же хочется видеть страницу состояния портов коммутатора когда сыпет. Нет ли там спящих устройств с линком в 10Mbit например. Если таковые есть, то вариант только один - вырубить auto negotinate для них и задать скорость максимально поддерживаемую. Так же возможно покрутить Flow Control на коммутаторе в сторону проблемных устройств.
  5. Крайне желательно на время проверки и повторения отрубить физически все остальные устройства подключенные по проводу от роутера кроме проверяемого

Таким образом сузим круг поиска.

Из описания так и не понял. Как эти подсыпания выглядят. Как быстро появляются, как часто происходят и т.д.

 

 

Цитата: kip от 01/07/2020, 17:35

Еще на вкладке Network Diagnostics одолело сообщение

"Error evaluating /adm/net-overview-update.js: SyntaxError: missing } after property list"

У себя не наблюдаю. Браузер какой? Sadler, глянь.

Firefox 68.10 esr и на мабильном samsung internet

Цитата: sfstudio от 01/07/2020, 17:42

Я описывал в теме на хоботе что нужно сделать и какие минимально данные предоставить. Вот с этого и начнём. Никакие tcpdump`ы тут не помогут.

Так же хочется видеть страницу состояния портов коммутатора когда сыпет. Нет ли там спящих устройств с линком в 10Mbit например.

Спящих нет, вот прямо сейчас вынул провод второй приставки, осталась приставка и ПК. Мобильных клиентов не подключено.

 

Для начала оставляем только ПК, проверяем на нём. Потом уже всё остальное. И конфиг мне на sfstudio[at]wi-cat.ru Без этого дальше не двенимся.

Опять же на всех сыпет или нет.

Ещё мысль пришла. Некоторые провайдеры, в целях препятствования ретрансляции мультикаста, корёжат TTL. В итоге устройства в выделенном порту будут работать нормально, а через роутер возможны любые чудеса в зависимости от фантазии провайдера. В misc->others для обхода этого есть опция Do not modify multicast TTL что бы роутер не уменьшал на 1 ТТЛ.

Вот сейчас сыпит и настройки минимальные, только пароль на вайфай стандартный стоит после сброса. Если речь идет о счетчиках на портах то я незнаю как их считать.

Счётчики на портах тоже ни чем не помогут. Если бы ошибки были бы на уровне физики то были бы и при конфигурации в IPTV мостом.

Ещё раз. Для начала оставляем только ПК и проверяем на нём.

Поток IPTV шифрован на ПК не посмотреть, вчера выделял порт, без vlan, просто выбрал порт и перезагрузил приставку, внешний ip прилетал на приставку, тоже сыпало. Конфиг это бэкап настроек?

вчера выделял порт, без vlan, просто выбрал порт и перезагрузил приставку, внешний ip прилетал на приставку, тоже сыпало

Ничего не понял. Вчера кто-то на хоботе отписался что в мосту не сыпет. Теперь уже и в мосту сыпит? А может и просто при втыкании кабеля напрямую в приставку теперь сыпит? Это-то проверили?

Просто в мост без vlan там вообще в софт ничего не попадает. Эти порты работают просто как порты равнозначные неуправляемого свитча.

Надо говорить что если и так сыпет, то проблему в роутере можно дальше не искать от слова совсем? Максимум что в ПО вообще влияет на коммутацию между такими портами (IPTV/SIP без VLAN) это настройки на страничке Switch Setup. Не ну можете там задать везде фиксированную скорость отрубить неготинэйт, flow control покрутить. На удачу что это коммутатор в роутере с вашим домовым свичтём не договорился и возможно танцы помогут.

Но вообще раз с VLAN не сыпет, а без сыпет (особенно второе т.к. в этом случае порты просто работают как банальный тупой свитч) надо вот провайдеру звонить и обяснять проблему.

Не сыпало когда на snr me1 выделял, либо HW_NAT binding threshold в 0 иначе под торрентом сыпало либо переодически зеленило. А тут не помогает не HW_NAT binding threshold в 0 ни выделение порта. Ставлю станый на тоже же место и ни намека на рассыпание :(

Как посмотреть есть ли ошибки на порте?

Причем если на snr заливаю прошивку 9.0.0 то поведение аналогичное становиться, я не знаю почему так происходит.

Ещё раз повторяю. В режиме IPTV port без VLAN трафик дальше коммутатора между этими портами вообще не выходит. Никакие настройки на это не влияют кроме тех которые я сказал. Не зависимо SNR там или не SNR.

ТЧК. Сравните настройки коммутатора на обоих девайсах.

Прошивка никак на это не влияет если речь о бридже IPTV/SIPTV без VLAN.

Вообще. Счётчики ошибок не вынесены никуда. Т.е. никак.

 

С 7.9.9 настройки встроенного коммутатора менялись? Что могло повлиять?

Выше всё описано что можно покрутить. Никто не мешает залить ту типа работающую 7.9.9 сбросить в дефолт открыть страничку настройки свичта и посмотреть.

Рыться в истории гита по SNR начиная с данных которым уже 2 года, что бы удовлетворить любопытсво ваше у меня времени увы нет. На память не помню. Ветка по SNR EOL можете её даже не вспоминать. Никто её даже на локальный комп сливать не будет что бы посмотреть.

Если интересно - на досуге можете сами слить с sf.net и посмотреть. Я на память не помню и мне это не очень интерсно.

 

В общем пробуйте. Вопросы все заданы, гадалки подключены, результаты гадалок выше требуют проверки. Да завтра я один фиг оффлайн. Завтра посмотрим. Ну если ответите на все вопросы заданные выше и проверите предположения начиная с включения приставки просто кабелем физически к прову, а то есть у меня предположение что оно и так сыпать будет, напрямую вообще без нечего. Ну раз в iptvbridge тупом сыпет.

Вообще с этого стоило начать кстати.

 

Хорошо попробую напрямую.

П.С. fastleave выключен.

Соединил напрямую через бочку, работает идеально.

Что-же теперь с этой железкой делать? Мыслей больше нет? Может с коммутатором провайдера конфликт какой нибудь или с настройками коммутатора.

Настройки порта крутил и fc отключал безрезультатно.

Попросить посмотреть ошибки по порту коммутатора на Tx на оборудовании оператора в момент просмотра ТВ и под нагрузкой последнее что остаётся. Rx Error даже если я вытщу сейчас эти данные куда-нить будут не показательны. Надо именно передающую сторону смотреть.

Просто надо понимать, что если IPTV port без влан подсыпает то там уже нет никакого ПО. Это просто коммутация между 2мя портами силами MT7530 коммутатора встроенного тут просто в один корпус с CPU.

Если WAN на сотку залочить тоже сыпет кстати?

Я конечно встречал в своей жизни что вот не хотели дружить 2 железки на уровне эзернета закатывая броадкаст штормы например. Но это я не знаю, один вариант на миллион.

Странно почему IPTV port + VLAN не сыпет. Хотя я до сих пор не услышал описания что значит сыпит. Раз в N часов 2 кадра рассыпалось это одно.

У нас не мало юзверей на онлайме так-то. Не слышал о проблемах от них вообще. Да и по iptv особенно с выделением порта проблемам взяться не где. Ну кроме момента что описывал со switchback для решения которой есть крутилка, а лучше таки на стороне оператора софт коммутаторов таки обновить и изоляцию между клиентами настроить. Но эта проблема к рассыпаниям точно отношения никакого не имела и не имеет.

В общем я даже не знаю что тут можно софтом сделать.

Винты все и прочее отключили на время тестов надеюсь? А то может таки попался БП с браком вот дроссель в итоге в  роутере запел, да эзернет трансмиттеры работают с ошибками не выдавая нужных уровней.

Эт уже ну совсем на правах заменителя хрустального шара.

Пока не перестанет сыпать в режиме IPTV port без VLAN дальше можно не разбираться. Т.к. этот режим польностью исключает влияение ПО оставляя только работу коммутатора аппаартного.

Не ну для проверки можно в разрыв оператор - WAN воткнуть свитч какой, ну если под рукой есть...

Поставил свитч и сыпать перестало, тестирую дальше. Также у меня на snr при включении Multicast to Unicast через некоторое время картинка замирала пока канал не переключишь, тут пока такова небыло, судя по тому что вы испавляли там зажато было igmp v2 похоже по этому и замирала картинка, а без Multicast to Unicast видимо переподписка проходила. Сейчас выставил igmp v3 и включил Multicast to Unicast пока все супер. HW_NAT binding threshold в 0 тоже поставил без нее появлялась зелень на экране раз в несколько минут, либо гарантировано когда торрент запускаю на 60 мегабайт.

Цитата: kip от 02/07/2020, 13:54

Поставил свитч и сыпать перестало, тестирую дальше.

Ну значит таки линк деградирует. Возможнос крутки по пути и т.д.

Также у меня на snr при включении Multicast to Unicast через некоторое время картинка замирала пока канал не переключишь, тут пока такова небыло, судя по тому что вы испавляли там зажато было igmp v2 похоже по этому и замирала картинка, а без Multicast to Unicast видимо переподписка проходила. Сейчас выставил igmp v3 и включил Multicast to Unicast пока все супер.

Там много чего правилось. igmpv3 и свитчбэк правился как раз под РТ. Онлайм они вроде купили тоже.

HW_NAT binding threshold в 0 тоже поставил без нее появлялась зелень на экране раз в несколько минут, либо гарантировано когда торрент запускаю на 60 мегабайт.

Крайне странно. Эта крутилка всего лишь задаёт когда к обработке будет подключен HWNAT. Чем выше значение - тем дольше устройство будет обрабатывать новые пакеты на cpu. Собсно когда порог превышен это значение ни на что вообще не влияет. 50ppps превышается даже просто сёрфингом. Не то что торрентами.

Более того, мультикаст в PPE вообще не попадает, он всегда обрабатывается софтово.

Я не могу объяснить этого поведения. Более того откровенно сомневаюсь в существовании подобного. Уж сорри. Нет связи тут. Вообще. Не откуда ей взяться.

Единственный возможный вариант когда она может влиять косвенно на транзит мультикаста, когда торрент запущен на самом роутере или проц в полку по какой-то причине. И то поведение несколько иное быть должно в теории. Т.к. локальный трафик не учитывается и подключаться PPE будет заметно позже.

 

Нет на роутере не запущен торрент, я пробовал разные значения HW_NAT binding threshold, пробовал уменьшать, но лишь при нуле IPTV становиться фиолетового на то как я канал использую. Я выше выкладывал дамп tcpdump там наверное есть адреса с которых идет трансляция мультикаста, они у РТ в разных регионах разные, возможно они не считаются мультикастом и не так приоритезируются. Вот уже часа два все ок, не тормазов заиканий, ни чего, идеально. Возможно PPE уберает очередь, обрабатывая отдельно трафик, и ядро или как там, занимается только мультикастом.

Цитата: kip от 02/07/2020, 15:05

занимается только мультикастом.

Далеко не всё оффлоадиться и всё равно дофига летит чисто в софте. Эти 50 pps погоды вообще не делают. Более того это было бы критично если бы проц был бы чем-то забит под завязку.

Так что у меня нет объяснения рационального на эту тему.

 

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: