Wi-CAT LLC

Wireless Comprehensive Advanced Technology. Build your network now.

Wi-CAT LLC
Навигация Форума
Вы должны войти, чтобы создавать сообщения и темы.

(решено) L2TPv3/EOIP в режиме ALL (в br0)

Добрый день,

Снова поднял эту тему...

Пока добавлял в бридж с eoip только беспроводные интерфейсы (ra0) все было ок. Когда понадобилось поставить eoip_brifs=all (т.е. добавить eoip в br0), то ничего не вышло - ни через вэб, ни через cli... . Пробовал и на 7.3.20, и на 7.5.32, и на 7.7.11..

Попробовал вручную через brctl перенести eoip0 из breoip в br0 - все работает ок...

Проверьте, плз, и скорректируйте по возможности ...

Что именно не вышло-то? Конфиг какой? Лог? Я ж как бы локально-то проверял всё это, и НАГ должен был перепроверить. Видимо что-то ещё в конфиге мешает надо смотреть и устранять конфликт. Без подробностей я ничего сделать не могу.

Ну и почему репорт по существующему функционалу не в разделе репорты? Ну не сложно ведь как-то делить и тему нормально до кучи назвать? Сейчас за вас поправил, в следующий раз снесу просто. Большая просьба больше так не делать, как и к репортам к любым прикладывать логи, нормально описывать что не получилось, как это выглядит и конфиг туда же.

Репорты вида "подземный стук" разбираться не будут.

Набор базовых правил и рекомендаций по работе с форумом в общем и по репортам озвучен тут https://wi-cat.ru/forums/topic/prochti-menya/ и он не просто так, а что бы мне каждый раз не приходилось выспрашивать, вымораживать, а другим искать решение в не очевидных местах.

 

Сорри ...

При включении туннеля EOIP и установке режима ALL интерфейс eoip0 не переносится в бридж br0. Если перенести вручную, то все работает.

Логи и конфиг приложены.

Загруженные файлы:
  • Вам нужно войти, чтобы просматривать прикрепленные файлы..

Ок, завтра постараюсь глянуть, очень странно, что тестеры прохлопали, да я сам проверял. Пока не глянул режим то какой? AP Gateway? Или AP bridge?

AP Gateway

Ок. В лоб глянул не вижу проблемы, закончу с текущей фигушкой разборки сразу гляну.

Поправил, банальная очепятка. И из-за подобной же очепятки синтетика не проверяет этот режим. Поправил. Пока можете руками заюзав vi поправить и по fs save сохранить, войдёт в следующий билд. Сейчас собрать внепланово не могу разгребаю стиринг для 7615 и чую сутки-двое ещё просижу над ним.

diff --git a/etc/rc.d/W36ethtun b/etc/rc.d/W36ethtun
index ab56a9088..e4cb50368 100755
--- a/etc/rc.d/W36ethtun
+++ b/etc/rc.d/W36ethtun
@@ -107,7 +107,7 @@ eoipstart() {
.
     eoip add name eoip0 tunnel-id $eoip_tid $local remote $eoip_remote
.
-    if [ "$eoipb_rifs" == "all" ]; then
+    if [ "$eoip_brifs" == "all" ]; then
        $LOG "Add eoip interface to system LAN bridge"
        brctl addif br0 eoip0
        ip link set eoip0 up

 

7.8.5 c фиксом тут https://sourceforge.net/projects/wive-ng/files/wive-ng-mt/test-only/

Проверяем, отписываемся.

Проверил и заменой в скрипте, и прошивкой - по этому вопросу все ОК, работает...

Спасибо за быстрое разрешение проблемы!

Цитата: vik44 от 20/01/2019, 15:27

Проверил и заменой в скрипте, и прошивкой - по этому вопросу все ОК, работает...

Отлично.

Спасибо за быстрое разрешение проблемы!

Не за что, это как бы норма.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: